Oracle Developer는 특정 버전 JDK에서만 실행이 됩니다.

그런데 로컬에 설치된 디폴드 버전이 실행 버전보다 상위일때 문제가 발생합니다.

이럴때 하위 버전이나 특정버전으로 셋팅할수 있습니다.


export JAVA_HOME=$(/usr/libexec/java_home -v 1.7)


posted by 뚱2

트위터 팔로잉 하는 @beyondj2ee님의 글을 인용


톰캣홈/lib로 이동해서 아래 명령어 실행


java -cp catalina.jar org.apache.catalina.util.ServerInfo


#결과

Server version: Apache Tomcat/7.0.52

Server built:   Feb 13 2014 10:24:25

Server number:  7.0.52.0

OS Name:        Mac OS X

OS Version:     10.9.2

Architecture:   x86_64

JVM Version:    1.8.0-b132

JVM Vendor:     Oracle Corporation


posted by 뚱2

 

// 스프링 버전 확인하기

org.springframework.core.SpringVersion.getVersion() 

posted by 뚱2

링크 : http://msdn.microsoft.com/ko-kr/library/ms378422.aspx

 

JDK 1.4.2에서는 sqljdbc 1.2만 지원된다. ㅡㅡ;

sqljdbc2, 4는 JDK 1.5 이상에서 지원

 

 

 

sqljdbc-1.2.jar

 

sqljdbc2.jar

 

sqljdbc4.jar

posted by 뚱2
1. 터미널이든 로컬이든 우선 접속한다. ^^

2. 명령 프롬프트에 ' SELECT version()'입력한다.
posted by 뚱2